File Formats vfstab(4)
NAMEvfstab - table of file system defaults
DESCRIPTIONThe file /etc/vfstab describes defaults for each file sys- tem. The information is stored in a table with the following column headings: device device mount FS fsck mount mount to mount to fsck point type pass at boot options The fields in the table are space-separated and show the resource name (device to mount), the raw device to fsck (device to fsck), the default mount directory mount(point), the name of the file system type (FS type), the number used by fsck to decide whether to check the file system automat- ically (fsck pass), whether the file system should be mounted automatically by mountall mount(at boot), and the file system mount options mount(options). (See respective mount file system man page below in SEE ALSO for mount options.) A '-' is used to indicate no entry in a field. This may be used when a field does not apply to the resource being mounted. The getvfsent(3C) family of routines is used to read and write to /etc/vfstab. /etc/vfstab may be used to specify swap areas. An entry so specified, (which can be a file or a device), will automat- ically be added as a swap area by the /sbin/swapadd script when the system boots. To specify a swap area, the device- to-mount field contains the name of the swap file or device, the FS-type is "swap", mount-at-boot is "no" and all other fields have no entry.
SEE ALSOfsck(1M), mount(1M), mount_cachefs(1M), mount_hsfs(1M), mount_nfs(1M), mount_tmpfs(1M), mount_ufs(1M), swap(1M), getvfsent(3C) System Administration Guide, Volume 1 SunOS 5.8 Last change: 17 Aug 1999 1