Maintenance Commands fsck(1M)
NAMEfsck - check and repair file systems
SYNOPSISfsck [ -F FSType ] [ -m ] [ -V ] [ special ... ] fsck [ -F FSType ] [ -n | N | y | Y ] [ -V ] [ -o FSType-specific-options ] [ special ... ]
DESCRIPTIONfsck audits and interactively repairs inconsistent file system conditions. If the file system is inconsistent the default action for each correction is to wait for the user to respond yes or no. If the user does not have write permission fsck defaults to a no action. Some corrective actions will result in loss of data. The amount and sever- ity of data loss may be determined from the diagnostic out- put. FSType-specific-options are options specified in a comma- separated (with no intervening spaces) list of options or keyword-attribute pairs for interpretation by the FSType- specific module of the command. special represents the character special device on which the file system resides, for example, /dev/rdsk/c1t0d0s7. Note: the character special device, not the block special device, should be used. fsck will not work on a block device if it is mounted. If no special device is specified fsck checks the file sys- tems listed in in /etc/vfstab. Those entries in /etc/vfstab" which have a character special device entry in the fsckdev field and have a non-zero numeric entry in the fsckpass field will be checked. Specifying -F FSType limits the file systems to be checked to those of the type indicated. If special is specified, but -F is not, the file system type will be determined by looking for a matching entry in /etc/vfstab. If no entry is found, the default local file system type specified in /etc/default/fs will be used. If a file system type supports parallel checking, for exam- ple, ufs, some file systems eligible for checking may be checked in parallel. Consult the file system-specific man page (for example, fsck_ufs(1M)) for more information.
OPTIONSThe following generic options are supported: -F FSType Specify the file system type on which to operate. SunOS 5.8 Last change: 16 Sep 1996 1 Maintenance Commands fsck(1M) -m Check but do not repair. This option checks that the file system is suitable for mounting, returning the appropriate exit status. If the file system is ready for mounting, fsck displays a message such as: ufs fsck: sanity check: /dev/rdsk/c0t3d0s1 okay -n | -N Assume a no response to all questions asked by fsck; do not open the file system for writing. -V Echo the expanded command line but do not execute the command. This option may be used to verify and to validate the command line. -y | Y Assume a yes response to all questions asked by fsck. -o specific-options These specific-options can be any combination of the following separated by commas (with no intervening spaces). b=n Use block n as the super block for the file sys- tem. Block 32 is always one of the alternate super blocks. Determine the location of other super blocks by running newfs(1M) with the -Nv options specified. c If the file system is in the old (static table) format, convert it to the new (dynamic table) format. If the file system is in the new format, convert it to the old format provided the old format can support the file system configura- tion. In interactive mode, fsck will list the direction the conversion is to be made and ask whether the conversion should be done. If a negative answer is given, no further operations are done on the file system. In preen mode, the direction of the conversion is listed and done if possible without user interaction. Conversion in preen mode is best used when all the file systems are being converted at once. The format of a file system can be determined from the first line of output from fstyp(1M). Note: the c option is seldom used and is included only for compatibility with pre-4.1 releases. There is no guarantee that this option will be included in future releases. SunOS 5.8 Last change: 16 Sep 1996 2 Maintenance Commands fsck(1M) f Force checking of file systems regardless of the state of their super block clean flag. p Check and fix the file system non-interactively ("preen"). Exit immediately if there is a prob- lem requiring intervention. This option is required to enable parallel file system check- ing. w Check writable file systems only. EXIT STATUS 0 file system is okay and does not need checking 1 erroneous parameters are specified 32 file system is unmounted and needs checking (fsck -m only) 33 file system is already mounted 34 cannot stat device 36 uncorrectable errors detected - terminate normally 37 a signal was caught during processing 39 uncorrectable errors detected - terminate immediately 40 for root, same as 0. USAGE See largefile(5) for the description of the behavior of fsck when encountering files greater than or equal to 2 Gbyte ( 2 **31 bytes).
FILES/etc/default/fs" default local file system type. Default values can be set for the following flags in /etc/default/fs. For example: LOCAL=ufs. LOCAL The default partition for a command if no FSType is specified. /etc/vfstab" list of default parameters for each file system
ATTRIBUTESSunOS 5.8 Last change: 16 Sep 1996 3 Maintenance Commands fsck(1M) See attributes(5) for descriptions of the following attri- butes: ____________________________________________________________ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | |_____________________________|_____________________________| | Availability | SUNWcsu | |_____________________________|_____________________________|
SEE ALSOclri(1M), crash(1M), fsck_cachefs(1M), fsck_s5fs(1M), fsck_ufs(1M), fsdb_ufs(1M), fsirand(1M), fstyp(1M), mkfs(1M), mkfs_ufs(1M), mountall(1M), newfs(1M), reboot( 1M), fs_ufs(4), vfstab(4), attributes(5), largefile(5) WARNINGS The operating system buffers file system data. Running fsck on a mounted file system can cause the operating system's buffers to become out of date with respect to the disk. For this reason, the file system should be unmounted when fsck is used. If this is not possible, care should be taken that the system is quiescent and that it is rebooted immediately after fsck is run. Quite often, however, this will not be sufficient. A panic will probably occur if run- ning fsck on a file system modifies the file system.
NOTESThis command may not be supported for all FSTypes. Running fsck on file systems larger than 2 Gb fails if the user chooses to use the block interface to the device: fsck /dev/dsk/c?t?d?s? rather than the raw (character special) device: fsck /dev/rdsk/c?t?d?s? SunOS 5.8 Last change: 16 Sep 1996 4