Maintenance Commands mountall(1M)
NAMEmountall, umountall - mount, unmount multiple file systems
SYNOPSISmountall [ -F FSType ] [ -l | -r ] [ file_system_table ] umountall [ -k ] [ -s ] [ -F FSType ] [ -l | -r ] umountall [ -k ] [ -s ] [ -h host ]
DESCRIPTIONmountall is used to mount file systems specified in a file system table. The file system table must be in vfstab(4) format. If no file_system_table is specified, /etc/vfstab" will be used. If `-' is specified as file_system_table, mountall will read the file system table from the standard input. mountall only mounts those file systems with the mount at boot field set to yes in the file_system_table. Each file system which has an fsckdev entry specified in the file system table will be checked using fsck(1M) in order to determine if it may be safely mounted. If the file system does not appear mountable, it is fixed using fsck before the mount is attempted. File systems with a `-' entry in the fsckdev field will be mounted without first being checked. umountall causes all mounted file systems except root, /usr, /var, /var/adm, /var/run, /proc, and /dev/fd to be unmounted. If the FSType is specified, mountall and umoun- tall limit their actions to the FSType specified. There is no guarantee that umountall will unmount busy filesystems, even if the -k option is specified.
OPTIONS-F Specify the FSType of the file system to be mounted or unmounted. -h host Unmount all file systems listed in /etc/mnttab that are remote-mounted from host. -k Use the fuser -k mount-point command. See the fuser(1M) for details. The -k option sends the SIG- KILL signal to each process using the file. As this option spawns kills for each process, the kill mes- sages may not show up immediately. There is no guaran- tee that umountall will unmount busy filesystems, even if the -k option is specified. -l Limit the action to local file systems. SunOS 5.8 Last change: 4 May 1999 1 Maintenance Commands mountall(1M) -r Limit the action to remote file system types. -s Do not perform the umount operation in parallel.
FILES/etc/mnttab" mounted file system table /etc/vfstab" table of file system defaults
ATTRIBUTESSee attributes(5) for descriptions of the following attri- butes: ____________________________________________________________ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | |_____________________________|_____________________________| | Availability | SUNWcsu | |_____________________________|_____________________________|
SEE ALSOfsck(1M), fuser(1M), mount(1M), mnttab(4), vfstab(4), attri- butes(5)
DIAGNOSTICSNo messages are printed if the file systems are mountable and clean. Error and warning messages come from fsck(1M) and mount(1M). SunOS 5.8 Last change: 4 May 1999 2