File Formats services(4)
NAMEservices - Internet services and aliases
DESCRIPTIONThe services file is a local source of information regard- ing each service available through the Internet. The ser- vices file can be used in conjunction with or instead of other services sources, including the NIS maps "services.byname" and the NIS+ table "services." Programs use the getservbyname(3SOCKET) routines to access this information. The services file contains an entry for each service. Each entry has the form: service-name port/protocol aliases service-name This is the official Internet service name. port/protocol This field is composed of the port number and protocol through which the service is provided (for instance, 512/tcp). aliases This is a list of alternate names by which the service might be requested. Fields can be separated by any number of SPACE and/or TAB characters. A `#' (number sign) indicates the beginning of a comment; characters up to the end of the line are not inter- preted by routines which search the file. Service names may contain any printable character other than a field delimiter, NEWLINE, or comment character.
FILES/etc/nsswitch.conf" configuration file for name-service switch
SEE ALSOgetservbyname(3SOCKET), inetd.conf(4), nsswitch.conf(4)
NOTES/etc/inet/services is the official SVR4 name of the services file. The symbolic link /etc/services exists for BSD SunOS 5.8 Last change: 22 Feb 1994 1 File Formats services(4) compatibility. SunOS 5.8 Last change: 22 Feb 1994 2