Maintenance Commands reboot(1M)
NAMEreboot - restart the operating system
SYNOPSIS/usr/sbin/reboot [ -dlnq ] [ boot arguments ]
DESCRIPTIONThe reboot utility restarts the kernel. The kernel is loaded into memory by the PROM monitor, which transfers control to the loaded kernel. Although reboot can be run by the super-user at any time, shutdown(1M) is normally used first to warn all users logged in of the impending loss of service. See shutdown(1M) for details. The reboot utility performs a sync(1M) operation on the disks, and then a multi-user reboot is initiated. See init(1M) for details. The reboot utility normally logs the reboot to the system log daemon, syslogd(1M), and places a shutdown record in the login accounting file /var/adm/wtmpx. These actions are inhibited if the -n or -q options are present. Normally, the system will reboot itself at power-up or after crashes.
OPTIONS-d Force a system crash dump before rebooting. See dumpadm(1M) for information on configuring system crash dumps. -l Suppress sending a message to the system log daemon, syslogd(1M) about who executed reboot. -n Avoid the sync(1M) operation. Use of this option can cause file system damage. -q Quick. Reboot quickly and ungracefully, without shut- ting down running processes first. bootarguments These arguments are accepted for compatibility, and are passed unchanged to the uadmin(2) function. EXAMPLES Example 1: Example of the reboot utility. In the example below, the delimiter `--' (two hyphens) must be used to separate the options of reboot from the argu- ments of boot(1M). SunOS 5.8 Last change: 30 Mar 1999 1 Maintenance Commands reboot(1M) example# reboot -dl -- -rv
FILES/var/adm/wtmpx login accounting file
ATTRIBUTESSee attributes(5) for descriptions of the following attri- butes: ____________________________________________________________ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | |_____________________________|_____________________________| | Availability | SUNWcsu | |_____________________________|_____________________________|
SEE ALSOboot(1M), crash(1M), dumpadm(1M), fsck(1M), halt(1M), init(1M), shutdown(1M), sync(1M), syslogd(1M), uadmin(2), reboot(3C), attributes(5) SunOS 5.8 Last change: 30 Mar 1999 2