Maintenance Commands savecore(1M)
NAMEsavecore - save a crash dump of the operating system
SYNOPSIS/usr/bin/savecore [ -Lvd ] [ -f dumpfile ] directory
DESCRIPTIONThe savecore utility saves a crash dump of the kernel (assuming that one was made) and writes a reboot message in the shutdown log. It is invoked by the /etc/init.d/savecore file after the system boots, if savecore is enabled by way of dumpadm(1M). savecore is enable on reboot by default. The savecore utility checks the crash dump to be certain it corresponds with the version of the operating system currently running. If it does, savecore saves the crash dump data in the file directory/vmcore.n and the kernel's namel- ist in directory/unix.n. The trailing .n in the pathnames is replaced by a number which grows every time savecore is run in that directory. Before writing out a crash dump, savecore reads a number from the file directory/minfree. This is the minimum number of kilobytes that must remain free on the file system con- taining directory. If after saving the crash dump the file system containing directory would have less free space the number of kilobytes specified in minfree, the crash dump is not saved. if the minfree file does not exist, savecore assumes a minfree value of 1 megabyte. The savecore utility also logs a reboot message using facil- ity LOG_AUTH (see syslog(3C)). If the system crashed as a result of a panic, savecore logs the panic string too.
OPTIONSThe following options are supported: -L Save a crash dump of the live running Solaris system, without actually rebooting or altering the system in any way. This option forces savecore to save a live snapshot of the system to the dump device, and then immediately to retrieve the data and to write it out to a new set of crash dump files in the specified directory. Live system crash dumps may only be performed if you have configured your system to have a dedicated dump device using dumpadm(1M). -v Verbose. Enables verbose error messages from savecore. -d Disregard dump header valid flag. Force savecore SunOS 5.8 Last change: 11 Dec 1998 1 Maintenance Commands savecore(1M) to attempt to save a crash dump even if the header information stored on the dump device indicates the dump has already been saved. -f dumpfile Attempt to save a crash dump from the specified file instead of from the system's current dump device. This option may be useful if the information stored on the dump device has been copied to an on-disk file by means of the dd(1M) command. directory Save the crash dump files to the specified direc- tory. If no directory argument is present on the command line, savecore saves the crash dump files to the default savecore directory, configured by the dumpadm(1M) command.
FILESdirectory/vmcore.n directory/unix.n directory/bounds directory/minfree /dev/ksyms the kernel namelist /etc/init.d/savecore /var/crash/'uname -n' default crash dump directory
ATTRIBUTESSee attributes(5) for descriptions of the following attri- butes: ____________________________________________________________ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | |_____________________________|_____________________________| | Availability | SUNWcsu (32-bit) | |_____________________________|_____________________________| | | SUNWcsxu (64-bit) | |_____________________________|_____________________________|
SEE ALSOSunOS 5.8 Last change: 11 Dec 1998 2 Maintenance Commands savecore(1M) adb(1), crash(1M),dd(1M), dumpadm(1M), syslog(3C), attri- butes(5) BUGS If the dump device is also being used as a swap device, you must run savecore very soon after booting, before the swap space containing the crash dump is overwritten by programs currently running. SunOS 5.8 Last change: 11 Dec 1998 3