ping

 


 
 
 
 Maintenance Commands                                     ping(1M)
 
 
 


NAME

ping - send ICMP (ICMP6) ECHO_REQUEST packets to network hosts

SYNOPSIS

/usr/sbin/ping host [ timeout ] /usr/sbin/ping -s [ -l | -U ] [ -adlLnrRv ] [ -A addr_family ] [ -c traffic_class ] [ -g gateway [ -g gateway ... ] ] [ -F flow_label ] [ -I interval ] [ -i interface ] [ -P tos ] [ -p port ] [ -t ttl ] host [ data_size ] [ count ]

DESCRIPTION

The utility ping utilizes the ICMP (ICMP6 in IPv6) protocol's ECHO_REQUEST datagram to elicit an ICMP (ICMP6) ECHO_RESPONSE from the specified host or network gateway. If host responds, ping will print host is alive on the standard output and exit. Otherwise, after timeout seconds, it will write no answer from host The default value of timeout is 20 seconds. When the -s flag is specified, ping sends one datagram per second (adjustable with -I) and prints one line of output for every ECHO_RESPONSE that it receives. No output is pro- duced if there is no response. In this second form, ping computes round trip times and packet loss statistics; it displays a summary of this information upon termination or timeout. The default data_size is 56 bytes, or you can specify a size with the data_size command-line argument. If an optional count is specified, ping sends ping requests until it either sends count requests or receives count replies. When using ping for fault isolation, first ping the local host to verify that the local network interface is running.

OPTIONS

The following options are supported: -A addr_family Specify the address family of the target host. addr_family can be either inet or inet6. Address family determines which protocol to use. For an argument of inet, IPv4 is used. For inet6, IPv6 is used. SunOS 5.8 Last change: 7 Sep 1999 1 Maintenance Commands ping(1M) By default, if the name of a host is provided, not the literal IP address, and a valid IPv6 address exists in the name service database, ping will use this address. Otherwise, if the name service database contains an IPv4 address, it will try the IPv4 address. Specify the address family inet or inet6 to over- ride the default behavior. If the argument speci- fied is inet, ping will use the IPv4 address associated with the hostname. If none exists, ping will state that the host is unknown and exit. It will not try to determine if an IPv6 address exists in the name service database. If the specified argument is inet6, ping will use the IPv6 address that is associated with the hostname. If none exists, ping will state that the host is unknown and exit. -a ping all of the addresses, both IPv4 and IPv6, of the multi-homed destination. The output will appear like ping has been run once for each IP address of the destination. If this option is used together with -A, ping probes only the addresses that are of the specified address fam- ily. When used with the -s option and count is not specified, ping continuously probes the des- tination addresses in a round robin fashion. if count is specified, ping will send count number of probes to each IP address of the destination and then exit. -c traffic_class Specify the traffic class of probe packets. The value must be an integer in the range from 0 to 255. Gateways along the path may route the probe packet differently depending upon the value of traffic_class set in the probe packet. This option is valid only on IPv6. -d Set the SO_DEBUG socket option. -F flow_label Specify the flow label of probe packets. The value must be an integer in the range from 0 to 1048575. This option is valid only on IPv6. -g gateway Specify a loose source route gateway so that the probe packet goes through the specified host along the path to the target host. The maximum SunOS 5.8 Last change: 7 Sep 1999 2 Maintenance Commands ping(1M) number of gateways is 8 for IPv4 and 127 for IPv6. Note that some factors such as the link MTU can further limit the number of gateways for IPv6. -i interface_address Specify the outgoing interface address to use for multicast packets for IPv4 and both multicast and unicast packets for IPv6. The default interface address for multicast packets is determined from the (unicast) routing tables. interface_address can be a literal IP address, for example, 10.123.100.99, or an interface name, for example, le0, or an interface index, for example 2. -I interval Turn on the statistics mode and specify the interval between successive transmissions. The default is one second. See the discussion of the -s option. -l Use to send the probe packet to the given host and back again using loose source routing. Usu- ally specified with the -R option. If any gate- ways are specified using -g, they are visited twice, both to and from the destination. This option is ignored if the -U option is used. -L Turn off loopback of multicast packets. Normally, if there are members in the host group on the outgoing interface, a copy of the multicast pack- ets will be delivered to the local machine. -n Show network addresses as numbers. ping normally displays addresses as host names. -P tos Set the type of service (tos) in probe packets to the specified value. The default is zero. The value must be an integer in the range from 0 to 255. Gateways also in the path may route the probe packet differently depending upon the value of tos that is set in the probe packet. This option is valid only on IPv4. -p port Set the base UDP port number used in probes. This option is used with the -U option. The default base port number is 33434. The ping utility starts setting the destination port number of UDP packets to this base and increments it by one at each probe. SunOS 5.8 Last change: 7 Sep 1999 3 Maintenance Commands ping(1M) -r Bypass the normal routing tables and send directly to a host on an attached network. If the host is not on a directly-attached network, an error is returned. This option can be used to ping a local host through an interface that has been dropped by the router daemon. See in.routed(1M). -R Record route. Sets the IPv4 record route option, which will store the route of the packet inside the IPv4 header. The contents of the record route will only be printed if the -v and -s options are given. They will only be set on return packets if the target host preserves the record route option across echos, or the -l option is given. This option is valid only on IPv4. -s Send one datagram per second and collect statis- tics. -t ttl Specify the IPv4 time to live, or IPv6 hop limit, for unicast and multicast packets. The default time to live (hop limit) for unicast packets is set with ndd(1M) using the icmp_def_ttl vari- able. The default time to live (hop limit) for multicast is one hop. -U Send UDP packets instead of ICMP (ICMP6) packets. ping sends UDP packets to consecutive ports expecting to receive back ICMP (ICMP6) PORT_UNREACHABLE from the target host. -v Verbose output. List any ICMP (ICMP6) packets, other than replies from the target host.

OPERANDS

host The network host EXAMPLES Example 1: Using ping With IPv6 This example shows ping sending probe packets to all the IPv6 addresses of the host london, one at a time. It sends an ICMP6 ECHO_REQUEST every second until user interrupts it. istanbul% ping -s -A inet6 -a london PING london: 56 data bytes 64 bytes from london (4::114:a00:20ff:ab3d:83ed): icmp_seq=0. time=2. ms 64 bytes from london (fec0::114:a00:20ff:ab3d:83ed): icmp_seq=1. time=1. ms 64 bytes from london (4::114:a00:20ff:ab3d:83ed): icmp_seq=2. time=1. ms SunOS 5.8 Last change: 7 Sep 1999 4 Maintenance Commands ping(1M) 64 bytes from london (fec0::114:a00:20ff:ab3d:83ed): icmp_seq=3. time=1. ms 64 bytes from london (4::114:a00:20ff:ab3d:83ed): icmp_seq=4. time=1. ms 64 bytes from london (fec0::114:a00:20ff:ab3d:83ed): icmp_seq=5. time=1. ms ^C ----london PING Statistics---- 6 packets transmitted, 6 packets received, 0% packet loss round-trip (ms) min/avg/max = 1/1/2 EXIT STATUS The following exit values are returned: 0 Successful operation; the machine is alive. non-zero An error has occurred; either a malformed argument has been specified, or the machine was not alive.

ATTRIBUTES

See attributes(5) for descriptions of the following attri- butes: ____________________________________________________________ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | |_____________________________|_____________________________| | Availability | SUNWcsu | |_____________________________|_____________________________|

SEE ALSO

ifconfig(1M), in.routed(1M), ndd(1M), netstat(1M), rpcinfo(1M), traceroute(1M), attributes(5), icmp(7P), icmp6(7P) SunOS 5.8 Last change: 7 Sep 1999 5