Firewall commands - aaa-server


Specify an AAA server. (Configuration mode.)

[no] aaa-server group_tag (if_name) host server_ip key timeout seconds

aaa-server group_tag protocol auth_protocol

aaa-server radius-acctport port

aaa-server radius-authport port

clear aaa-server [group_tag]

show aaa-server


aaa-server

Specifies an AAA server or up to 14 groups of servers with a maximum of 14 servers each. Certain types of AAA services can be directed to different servers. Services can also be set up to fail over to multiple servers.

group_tag

An alphanumeric string which is the name of the server group. Use the group_tag in the aaa command to associate aaa authentication and aaa accounting command statements to an AAA server. Up to 14 server groups are permitted.

if_name

The interface name on which the server resides.

host server_ip

The IP address of the TACACS+ or RADIUS server.

key

A case-sensitive, alphanumeric keyword of up to 127 characters that is the same value as the key on the TACACS+ server. Any characters entered past 127 are ignored. The key is used between the client and server for encrypting data between them. The key must be the same on both the client and server systems. Spaces are not permitted in the key, but other special characters are.

timeout seconds

A retransmit timer that specifies the duration that the PIX Firewall retries access four times to the AAA server before choosing the next AAA server. The default is 5 seconds. The maximum time is 30 seconds.

For example, if the timeout value is 10 seconds, PIX Firewall retransmits for 10 seconds and if no acknowledgment is received, tries three times more for a total of 40 seconds to retransmit data before the next AAA server is selected.

protocol auth_protocol

The type of AAA server, either TACACS+ or radius.

aaa-server radius-acctport

Sets the port number of the RADIUS server which the PIX Firewall unit will use for accounting functions. The default port number used for RADIUS accounting is 1646.

aaa-server radius-authport

Sets the port number of the RADIUS server which the PIX Firewall will use for authentication functions. The default port number used for RADIUS authentication is 1645.

port

Specifies the destination TCP/UDP port number of the remote RADIUS server host to which you wish to assign authentication or accounting functions for the PIX Firewall.

These port pairs are listed as assigned to authentication and accounting services on RADIUS servers:

  1. 1645 (authentication), 1646 (accounting) - default for PIX Firewall

  2. 1812 (authentication), 1813 (accounting) - alternate

You can view these and other commonly used port number assignments online at the following website:

http://www.iana.org/assignments/port-numbers
See "Ports" in "Using PIX Firewall Commands" for additional information.

no aaa-server

Unbinds an AAA server from and interface or host.

show aaa-server

Displays configuration information of an AAA server in the configuration.

clear aaa-server

Removes an AAA server from the configuration.


Defaults

By default, the PIX Firewall listens for RADIUS on ports 1645 for authentication and 1646 for accounting.


Usage

The aaa-server command allows you to specify an AAA server group. PIX Firewall lets you define separate groups of TACACS+ or RADIUS servers for specifying different types of traffic; such as, a TACACS+ server for inbound traffic and another for outbound traffic. Another use is where all outbound HTTP traffic will be authenticated by a TACACS+ server, and all inbound traffic will use RADIUS

AAA server groups are defined by a tag name that directs different types of traffic to each authentication server. If the first authentication server in the list fails, the AAA subsystem fails over to the next server in the tag group. You can have up to 14 tag groups and each group can have up to 14 AAA servers for a total of up to 196 AAA servers.

If the RADIUS server uses ports 1812 for authentication and 1813 for accounting you are required to reconfigure the PIX Firewall to use ports 1812 and 1813.

Note This is a global setting that takes effect when RADIUS service is started. The default ports are 1645 for authentication and 1646 for accounting as defined in RFC 2058. Newer RADIUS servers may use the port numbers 1812 and 1813 as defined in RFC 2138 and 2139. If the server uses ports other than 1645 and 1646, then you should define ports using the aaa-server radius-authport and aaa-server radius-acctport commands prior to starting the RADIUS service with the aaa-server command.

The aaa command references the tag group.

Note The previous server type option at the end of the aaa authentication and aaa accounting commands has been replaced with the aaa-server group tag. Backward compatibility with previous versions is maintained by the inclusion of two default protocols for TACACS+ and RADIUS.

If accounting is in effect, the accounting information goes only to the active server.

The default configuration provides these two aaa-server protocols:

aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius

Changing authorization and accounting port settings is possible. By default, PIX Firewall listens for RADIUS on ports 1645 and 1646. If the RADIUS server uses ports 1812 and 1813, you may also reconfigure it to use ports 1812 and 1813 with the aaa-server radius-authport and aaa-server radius-acctport commands.

If you are upgrading from a previous version of PIX Firewall and have aaa command statements in the configuration, using the default server groups allows you to maintain backward compatibility with the aaa command statements in the configuration.


Examples

  1. This example uses the default protocol TACACS+ with the aaa commands:

    aaa-server TACACS+ (inside) host 10.1.1.10 key timeout 20

    aaa authentication include any outbound 0 0 0 0 TACACS+

    aaa authorization include any outbound 0 0 0 0

    aaa accounting include any outbound 0 0 0 0 TACACS+

    aaa authentication serial console TACACS+

    This example specifies that the authentication server with the IP address 10.1.1.10 resides on the inside interface and is in the default TACACS+ server group. The next three command statements specify that any users starting outbound connections to any foreign host will be authenticated using TACACS+ that the users who are successfully authenticated are authorized to use any service, and that all outbound connection information will be logged in the accounting database. The last command statement specifies that access to the PIX Firewall unit's serial console requires authentication from the TACACS+ server.

  2. This example creates the AuthOut and AuthIn server groups for RADIUS authentication and specifies that servers 10.0.1.40, 10.0.1.41, and 10.1.1.2 on the inside interface provide authentication. The servers in the AuthIn group authenticate inbound connections, the AuthOut group authenticates outbound connections.

    aaa-server AuthIn protocol radius

    aaa-server AuthIn (inside) host 10.0.1.40 ab timeout 20

    aaa-server AuthIn (inside) host 10.0.1.41 abc timeout 4

    aaa-server AuthOut protocol radius

    aaa-server AuthOut (inside) host 10.1.1.2 abc123 timeout 15

    aaa authentication include any inbound 0 0 0 0 AuthIn

    aaa authentication include any outbound 0 0 0 0 AuthOut

  3. This example lists the commands that can be used to establish an Xauth crypto map:

    ip address inside 10.0.0.1 255.255.255.0

    ip address outside 168.20.1.5 255.255.255.0

    ip local pool dealer 10.1.2.1-10.1.2.254

    nat (inside) 0 access-list 80

    aaa-server TACACS+ host 10.0.0.2 secret123

    crypto ipsec transform-set pc esp-des esp-md5-hmac

    crypto dynamic-map cisco 4 set transform-set pc

    crypto map partner-map 20 ipsec-isakmp dynamic cisco

    crypto map partner-map client configuration address initiate

    crypto map partner-map client authentication TACACS+

    crypto map partner-map interface outside

    isakmp key cisco1234 address 0.0.0.0 netmask 0.0.0.0

    isakmp client configuration address-pool local dealer outside

    isakmp policy 8 authentication pre-share

    isakmp policy 8 encryption des

    isakmp policy 8 hash md5

    isakmp policy 8 group 1

    isakmp policy 8 lifetime 86400

    The aaa-server command is used with the crypto map command to establish an authentication association so that VPN clients are authenticated when they access the PIX Firewall.


    Related Commands

    1. crypto ipsec
    2. isakmp